Fezzik: Life Begins at 200K

I’m not sure I can even drive without AA now. I’d need to go to AA meetings or something. :thinking:

Double DIN easiness for you pal. I’d not do an android cheapie indash. Instead: Sony, Alpine or Pioneer. Sony is my choice. Well actually three choices, since there was a sony in all the 4wd’s at our place, until I sold the Prado a few weeks back.

XAV-AX3200 is pretty solid for good price. Not a lot of customizing backgrounds etc. but robust. Possible needs a screen film on it for glare depending on sun angle. Its so low in the gen2 that it likely just needs you sitting on the floor? One thing I did in gen2’s was redrill the mounting plates as much as I could get away with to angle the screen up ever so slightly. Some of the sonys are almost single DIN behind the double din face, so there may be room to do this a little easier?

1 Like

Thanks Phil. I think I want to go modular, though. Partly because I’ve never looked how double DINs looked, but mostly because I want the display up where it’s visible while driving.

The Mazda has spoiled me.

What’s the speed limit here? How fast am I actually going? If only there was an easier way of knowing these things!

In addition to a bigger, better, and fully integrated display, I’m also curious about adding a backup camera and blind spot warnings. Not sure if it’s worth the effort, though.

Okay, so check this out.

Apparently you can buy a super solid deck with screen and housing for under $400 from AliExpress. Not bad! But I’m also eyeing a modular Pioneer model, so maybe if I can just get the housing…

Iowa Fuel Tracking

Trying to get a sense of how much fuel I use now that I live in a small town.
PS: Here’s how to build a table in your post.

date days unit volume cost miles mpgs note
08.18.22 $4.399/gal 21.4gal $93.95 initial entry
08.28.22 10 $4.399/gal 7.1gal $31.08 pre-trip top-off
08.28.22 1 $4.399/gal 20.7gal $91.13 408mi 19.7mpg scenic byways, 50-60mph touring
08.29.22 1 $4.459/gal 20.2gal $89.92 286mi 14.2mpg interstate home, 70-80mph cruising

Fezzik broke his all-time fuel economy record this weekend. After spending the better part of the day farting along on 55-65mph, 2-lane backroads, I rolled into the pre-event dinner party at exactly 400 miles on the tank. 8-ish miles later, I filled up the tank and got a record-breaking 19.7mpg.

Imagine that. Driving slower returns better fuel economy. :stuck_out_tongue:


I’m feeling pressure to get our cars Fluid Filmed. Beyond 24 years of microscopic rock chips suddenly bringing an unfortunate orange tint to Fezzik’s bodywork, and the steel ADD bumper Josh and I painted on a rainy evening before the big Xmas trip in 2020, the leading edges of everything underneath has been sandblasted and is already coated in bright surface rust.

I need to drop all the skids, degrease, and pressure wash everything. Before I do, what do y’all think about me putting 50-ish miles of dirt/gravel road on the truck without armor to maybe organically knock some of that surface rust off before I pressure wash? (And is it a good idea to rinse Easy-Off oven cleaner into the street?)

It was 31°F/-1°C out this morning. I’m running out of pressure washer weather.

5 Weeks Later

I pressure washed Fez real good in the driveway. And then it rained, turning my parking spot into a mud puddle, causing me to sling thick, grimy clay all over the place. So I had to go back out to a DIY carwash and spend $16 pressure washing it all over again. (Not getting my hoses back out in these temps.)

Garage cleared out and the thickest plastic sheet they had at Harbor Fright laid, I went out after dinner thinking I’d just need an hour or so to casually spray the undercarriage with 2-3 cans of Surface Shield.

Without a doubt, the nastiest, most vile shit I have ever used in the automotive realm. It’s like WD-40 mixed with Vaseline and wet cat food. I kept the cans inside until I went out to do this. I set the box on top of the hood—which was still very warm. I shook each can within an inch of its life.

The long straws I bought to get into the frame rails simply popped out of the nozzle. The straws that came taped to the cans themselves popped out. After the second can, I stopped to fucking crazy glue the straws into the rest of the nozzles ahead of time. They’d pop out halfway through a can. 10% of the stuff gets out under the nozzle, covering the can with this foul slime.

I wore my worst work clothes; the kind I wouldn’t regret throwing away after this. I wore a disposable painter’s suit over, complete with hood. I bought new, wrap around safety googles and a bag of particle masks. It was still warm enough I opted to leave both garage doors open for cooling.

Six hours later, I had the skid plates back on (minus the one under the fuel tank so I can more easily rinse the salt out from between so many layers of tank, strap, and factory cover, had cleaned things up best I could, took a hot shower, and went to bed five hours before my alarm went off.

Everywhere I went in the garage that wasn’t covered in plastic had the same foul, greasy sheen that I had on every inch of uncovered skin. (Including my beard and the back of my head, after the the aforementioned hood fell off and I didn’t notice.)

Note to self: Next time, buy a gallon bucket and use a compressor to apply because damn.

A week later, it snowed! Though I didn’t need it at all, it was nice having the hubs locked and being able to leave it in AWD for a week or so. I even made the 2-hour drive to the Workiva home office in Ames (north of Des Moines) in some nasty grayness last week and back without so much as a hiccup.

Well, my dodgy windshield sprayers weren’t much help and I had to keep the defrost running full blast on recirc because the wind chill was such that coolant temps struggled to get above 185°F/85°C. I’ve had a sheet of cardboard blocking 70% of the radiator since the next day. Been watching temps and they stay right around 190 now. Sweet.

Chuck has spoiled me with his heated seats and steering wheel so I bought my own seat heater elements from Amazon a couple months back. The plan is to install them under my aftermarket seat covers rather than re-upholster the front seats to get at the original units (for now*) and hopefully lean on the factory harness and switches to make the job a little easier.

So I took apart my seat heater switches, cleaned them up, and replaced the dead T1 bulbs inside with LEDs. None of the LEDs work. Might be too much power on the switches. The hold switch works, though I’ve not confirmed the hold function, and only one of the heater switches illuminates the HI/LO indicators, so I’ll be pulling them back out for some proper continuity testing this week. Still, it was nice making progress.

*I’m thinking about just roughing in my electrical interior stuff so I can confirm functionality and be ready to clean things up come spring. I’ve got stuff in boxes going on two years now waiting for the interior to come out for the Noico install. I don’t even know if it all works at this point and it’s too late to return any of it, so might as well get after it.


Damn I’m glad they don’t use salt here. :face_with_monocle:

I surprisingly actually do not regret doing this on the Disco earlier this year. Just keep it tidy and well documented, and you can use the old wires to pull the new ones into place. :+1:t3:

1 Like

That’s how you did it? Sweet! I might get started this weekend! Among the more pressing projects on my automotive to-do list that could go in this way (approx. purchase date):

  • front seat heaters (Oct 22)
  • under-seat subwoofer (Mar 22)
  • second row reading lights (Nov 21)
  • (maybe all the aux lighting)

Other projects that feel pressing at the moment:

  • make sure front fenders are cleaned out (rust prevention)
  • install rubber sheeting to seal off chassis from wheel wells (Dec 22)
  • install Rally Armor splash guards (Mar 22)
  • install Noico insulation (weak heater)
  • install amber/white emergency flashers (for low-visibility recovery action)

I should also post an official, 6-months anniversary update. Working on it!

1 Like

8AM. 5 inches of snow on the ground. Eight more hours of snow predicted.
And Fezzik is barely drivable due to TPS-related bullshit.
Here’s what I’ve tried so far…

1 - Verified behavior.

  • Feels like the transmission is slipping, but it’s really just awful shift points.
  • Transmission won’t upshift without aggressive, almost-to-redline pulls and snap throttle lift-off.
  • TPS reading constant 99%, no matter how throttle moved—even when disconnected. :grimacing:
  • CEL P0120 for TPS (which also contains the closed throttle switch).

2 - Replaced the TPS sensor.

  • Fortunately, I had three spares lying around.
  • Two of these were DOA losers I bought from Amazon.
  • One was a Beck Arnley and tested good. Problem persists (except the 99% TPS reading).

3 - Followed TPS troubleshooting steps in FSM.

  • Confirmed TPS harness integrity
    – continuity of ground circuit to chassis
    – continuity of power and signal circuits to ECU
  • Confirmed ECU health
    – visual inspection of clean, dry ECU, harness, & connectors
    – confirmation of 5VDC to TPS from ECU

4 - Reinstalled both good TPS sensors multiple times.

  • Only two of the sensors I had on-hand gave a full sweep range of 0-100%.
    – Beck Arnley: 0-100% loose, 5-93% installed
    – “SKETCH” (the one I removed): 0-100% loose, 5-93% installed
  • Shitty, aggro shift pattern persists.

And this is where I stopped for the night, after nearly three hours of fruitless attempts in a cold garage with no garage door opener remote, two heaters going, and at least four test drives through the neighborhood at 4000-5000rpm in first/second gear.

So what do we know?

  • TPS is used more for determining transmission shift points than fueling.
  • TPS also incorporates a throttle closed switch that appears more lift-related than actually 100% closed.
  • The harness between the TPS and ECU is good.
  • The ECU is sending the correct 5VDC to the sensor.
  • I have two presumably good TPS sensors
    – Both are within spec for resistance, gain-over-range, and power.
    – Both have been installed/reinstalled at least 3X with increasing meticulousness.

All of the above leads me to believe I’m looking at one of two options:

  1. Both sensors have the same throttle closed failure, or
  2. I am doing something wrong at install.

It seems more likely to me that I’m the problem, here. I’ve always had TPS troubles. The only time I’ve ever installed one correctly without issue was when I had the MUT-II connected. I don’t have that luxury anymore, and so have been using a digital multi-meter.

I have tried adjusting the TPS by logger output through the ECU, trying to get the maximum range across the actual throttle blade sweep. Best I can do is 4-5% to 93%. (I’ve also tried a baseline of 25% to see if that affected the behavior. It didn’t.)

I’ve also tried adjusting the TPS by back-probing the sensor while connected to try setting things to where the throttle closed switch engages, but the FSM actually says to start that process by turning the sensor fully clockwise, then slowly turning back clockwise until the switch closes (OL). I’ve tried both directions. No joy.

There’s not a lot of ways to install these things. I am frustrated. Now I’m gonna go use my snow thrower so we can maybe get the new car with the 45-series tires on 20s out if we need to go anywhere in half a foot of snow.

1 Like


Built myself a test harness to go between the chassis harness connector and the sensor on the throttle body so I could check voltages while the sensor was connected (without back-probing the connector with needles).

Suspecting the throttle closed switch being the culprit (and I was back on the sketchy sensor that developed the issues earlier last week since it showed the same TPS sweep range as the NIB Beck-Arnley), I pulled the sketch TPS and swapped on the NIB again.

Now it was reading 0-93% sweep—but reporting WOT at closer to 50% actual throttle position.What. The actual. Fuck. I tried reinstalling it six ways from Sunday. It only goes on one way. I’m not sure why these things are adjustable, when they invariably can’t rotate far enough counter-clockwise to sit at <4% throttle at idle and I’ve never had a single one need rotating further clockwise whatsoever.

So I swapped the sketch unit back on to use my new harness to test the throttle closed switch. Only to find IT was now doing the same fucking thing—0-93% throttle input over about 50% of the available sensor sweep.

Still have a code for TPS. And it makes sense, too. If the ECU is seeing 93% throttle input despite my foot only being into the pedal about 45%, it would hold the gears and not upshift unless it physically had to.

The nearest Mitsubishi dealer is in Moline, IL, an hour away. (Near the dispensary, btw.) All the Mitsubishi OE Parts peddlers online apparently use the same inventory/pricing system and want >$200 for the TPS, so I had to buy one from PartSouq in Dubai. $147 and it will be here in about two weeks.


  • installed new, OEM TPS
  • properly adjusted kickdown cable

57,000 miles on the rebuilt engine. And last night Kevin Roy asks me if I’ve adjusted the transmission kickdown cable.

Long story short it was seriously out of spec. The stopper ferrule should rest against the cable end when closed, with a max distance of 35-38mm at WOT.

Damn truck has never shifted so smoothly in the entire time I’ve owned it. I’m excited to see what I can do with it now. I never felt it was a bad slushbox, but it’s such an improvement, I’m changing the way I drive it.

I might have kissed Fezzik tonight.

1 Like

10 Days Later I got stuck in Des Moines.

With Fezzik running so smoothly, I took advantage of the opportunity to drive 130 miles to Ames (basically a Des Moines suburb) to attend the literal passing of the baton between the founding CEO and his replacement. It was a great day. Until I went to leave that night.

4:30PM. Cloudy. Cold. Freezing rain turning to snow predicted. I leave the office parking lot and I’ll be damned if Fezzik didn’t start doing that no-shift bullshit again. Long story short, I spent 2 hours trying every trick in the book to get Fez drivable so I could get home. Nothing worked.

I called AAA, expecting to burn through two of my three, 100-mile tows for the year to get the truck home. Sadly, Mom neglected to renew everyone’s memberships as she was preparing to move to Iowa last November, so the best they could do for me was a 5-mile tow for $150 if I signed up over the phone.

Having spent enough time in the muddy, Iowa State University stadium RV parking lot re-re-re-adjusting the transmission control cable in the cold, I finally gave up and did the two miles back to the office parking lot at 25mph in a 45mph (40km in a 70) at 4,500rpm so I could abandon ship in the brightly lit, secure office parking lot.

7:00PM. Fully dark. Intermittent flurries. V was picking up her mom to stay with P while she did the 4-hour drive to pick me up and we’d count on the Des Moines Mitsubishi dealer (who still hasn’t returned my call) to collect and fix Fezzik in the morning. With two hours to kill, I considered watching Netflix or listening to music, but I was so pissed I just decided to check the logger one more time.

My bluetooth OBD scanner dongle wouldn’t connect, so I pulled it and reconnected it.

Suddenly, all systems were go again. TPS read right. Truck drove right.

I went around the block. Everything was okay.

I got on the highway to go home. Everything was okay.

I called V, who was now leaving town, telling her I was coming home and to stand down. I didn’t drop below 65mph until I got off the highway back in Iowa City. And Fezzik ran fine after that… for about a week.

In the next installment, I’ll get into why I’m pulling the entire interior to hopefully fix this phantom TPS issue once and for all…

TPS / ECU drama continues…

The two+ hours drive home provided plenty of time to think about (read: obsess over) what had happened, why it happened, and what it meant for the future. It didn’t make sense—and yet it did?

  • I thought the problem was Amazon TPS—but the problem came back with an OEM TPS.
  • I thought the problem was the cable adjustment—but the problem came back after it was set.

Staring out into the abyss through the windshield, I found myself wondering if the OBD scanner dongle was to blame. I mean, let’s see now…

  • I re-installed the TPS and re-adjusted the cable. The logger read 60% or 90% no matter what. Just like it had done on four other TPS I had lying around. Mechanically, I was set. Electrically, something was off.

  • But I had already traced the harness between the TPS and ECU a couple weeks before and verified it was intact and secure.; at least at either end where things were most likely to be moved. I also confirmed the ECU was sending the proper voltage to the TPS. So I should have been set, electrically, too.

:thinking: The only thing I did between the 4500rpm, 25mph drive to the office parking lot and the drive home was reconnect the scanner dongle to the OBD port under the dash. And here’s what THAT looked like…

  1. The logger was connected to my phone, but failed to connect to the ECU (for the first time ever).
  2. I disconnected from the dongle, closed the app, and then physically removed the dongle to reset it.
  3. The logger connected to the ECU first try, and then showed all systems nominal and ready.
  4. I drove around the block. Truck drove perfectly.
  5. I re-checked the logger. Now it was still logging, but ALL signals were frozen midstream. That is, the scales were still tracking time, but the signals were static/constant.

At that point, I was out of Ames and well on my way to Des Moines and the I-80 interchange. I closed the app and left the dongle installed because I wasn’t about to stop until I got home, let alone change something about the electrical system under these circumstances.

Was my ECU going bad? Did late-90s Mitsubishis have the same, leaky capacitor in the ECU issue as the early-90s Mitsubishis did? Was the no-name, $30 bluetooth dongle from Amazon—that had been connected and power-cycled almost daily for at least two years—acting up and somehow backfeeding noise through the OBD port?

Upon getting home, I pulled the dongle. The truck drove flawlessly for about a week. When the problem came back, it did so in the middle of an otherwise normal drive.

It was a rainy day. Fezzik had been outside in all of it. I took a dog to the groomer. As I was leaving the parking lot, I thought I felt the transmission slipping a bit, but I was getting on the highway so I crossed my fingers. 2 miles down the road, I exited the highway and it was clear things were about to get shitty again.

Over the course of maybe 5 miles, Fezzik went from driving perfectly fine to right back to being undriveable over 10mph. I roared the last two blocks home at 5000rpm at 20mph and he’s been in the garage ever since.

The kick panel was still off from when I traced the harness so I decided to pull the ECU and check for leaky caps. There were none. In fact, the ECU looked great, except for a stripe of rusty-brown surface corrosion across the back of the board. This corrosion cleaned up nicely, with minimal scrubbing with a new toothbrush and 99% isopropyl rubbing alcohol.

Removing the mud-crusted WeatherTech floormat in the process of getting in there, I discovered the carpet was wet (again). I pulled it back and found the insulation behind the rubber pad on the footwell was soaking wet. (Not seen, it was soaking wet all the way over to the center tunnel below the heater core, too, but did not smell at all like coolant. This was just water.) Was the windshield seal leaking? Had leaves or acorns or something gotten into my sunroof drains since I cleaned them in the fall? Where is the water coming from, and is it the cause of the fresh corrosion, and is that the cause of my struggles?

It’s looking like hanging the ECU over a sopping wet sponge for six months of winter might be taking a toll on the ECU. I’m hoping I can confirm the leaks, patch them, and get on with my life.

In the meantime, I’ve had the following items waiting on install, some of which going back to the fall of 2021:

  • sound insulation for the walls and ceiling
  • fiber optic, twinkle light headliner kit
  • powered subwoofer (under seat)
  • JL Audio 6x9 speakers
  • seat heaters & switches for front row
  • white/red LED reading lights for second row
  • gently used door gaskets from an AZ junkyard

So, as much as I hate the thought of taking my truck apart to this extent without being abso-friggin-lutely sure it’s the right thing to do, it’s something I’ve been wanting to do for almost two years and this is probably the best time of year to do it (before it gets hot and humid in the garage).

I figure, IF the issue is caused by a damp environment—and I KNOW I’ve got water ingress issues—it certainly can’t hurt to address the water-inside-the-cabin issue. Fortunately, I have a lot of neat shit to install that should make this project relatively fun. (It’s been years since I’ve installed any actual mods myself.) If I do all this and the truck STILL acts up, then I think I can probably start ECU shopping. Hell. I might keep an eye out for a spare CA-spec ECU just in case.


Omg fezzik! Why damn you!?

Sunroof drains would be my first guess too. I also think you’re on the right track suspecting the water causing the issue. It sucks. But…

Might’ve been like this in az forever but with a “dry heat” 90% of the time how would you ever know?

1 Like

All sounds fairly sucky. IMO, a spare ECU is a must. They’re not getting any more common or cheaper. I keep a spare properly packaged up in my truck at all times, and then have another in the garage. Overkill? Time will tell. See above for my reasoning.

What did you find out about the moisture? Where’s it coming from?

1 Like

No news on the water ingress, but I suspect we’re about to find out.

They’ve already announced school getting out an hour early because they’re so sure it’s coming.

I taped the windshield up with foil tape, so if the floor gets wet, I think we’ll be able to rule it out (but I’m hoping it stays dry so I can just re-seal the windshield.

1 Like

The windshield tape worked!

We had a couple-three days of shit weather, punctuated by some relatively heavy rain. I’m talking, wake you up in the middle of the night to look out the window at the river flowing down the sidewalk kinda rain. When I checked the carpet the next morning, it was bone dry all the way to the floorboard.

To seal or not to seal. That is the question!

I have several feet of thick, adhesive windshield gasket material I could use to reseal the windshield. But I also have a nice little crack coming from the edge of the windshield at the top suggesting I could (should?) get the windshield replaced, at which point, presumably, professionals would reseal the new windshield right.

I’ll probably try the stuff I bought from Amazon and see how it does for a couple months. A new windshield is at least $200 and I have gardening stuff to do. In the meantime, Brother Keith (not a member) recommended some silicone conformal coating spray to waterproof the ECU board.

A couple notes on that conformal coating stuff :point_up::

  1. It’s like liquid wax. Don’t get it on any contacts or connectors.
  2. This is apparently what they do to the insides of “Marine” electronics.

Upcoming Plans

I’ve got a lot of fun stuff to do and am excited to get started. The first step, however, is kinda cleaning up the garage to make room for complete interior removal, so that’s been my biggest deterrent so far. Thinking through things in a rough order, though…

  1. Make room in the garage for truck projects.
  2. Empty out the truck. Glovebox, door pockets, every nook and cranny.
  3. Remove the seats, center console, headliner, plastic trim, and carpet.
  4. Install new audio equipment (rear speakers, sub, possible amp).
  5. Install new house lighting (2nd row reading lights, etc.)
  6. Wire up new exterior aux lighting switch panel.
  7. Clean interior for insulation installation.
  8. Clean interior pieces for reinstallation.
  9. Fix headliner and install fiber optics.
  10. Put it all back together successfully.

I’ve also got a shit-ton of rear suspension bushings to go in. :thinking:

Miles to go before I sleep!

1 Like


  • upper & lower radiator hoses
  • heater hoses

One day before the Mazda is ready, Fez decides to piss coolant all over the driveway. Fortunately, this was after V&P ran errands.

Turned out the lower radiator hose relaxed into the AC clutch and was moments away from splitting wide open.

So I installed the new, silicone jobbers from ADD. I also used mule tape to tie the lower hose back out of the way, just in case.

Wouldn’t you know it–I drive to DSM for a work conference, get home, and the very next day, I’m smelling coolant again.

This time it was the heater hoses. Not sure why I used “PCV” hose instead of proper, glycol-resistant heater hose last time.

I’m looking for 5/8in (16mm) ID silicone heater hose with 90° bends on one end now…

1 Like

It was probably a temp setup when you swapped out the motor, yeah?

Could be. The shop that did the timing belt and all that before the move made a special call just to tell me I had the wrong kind of hose for all my coolant lines and I asked them to swap em all out. No idea why I would have had them skip those two–so why do I feel like I maybe might have?

The world may never know. For now, I’ve got to replace the heater core. It’s leaking pretty badly.

:point_up: That’s dripping from the puddle on the carpet in the second row. Between 8am and 1pm.

Freaking gross.

1 Like